[solved] How to Configure Mutt for my account?


#1

Hello !

I would like to configure mutt for my account…

this one doesn’t work…

Boîte de réception (elle s’appelle généralement INBOX sur un mail.indie.host IMAP)

set spoolfile=imap://mail.indie.host:993/INBOX

Dossier contenant les autres boîtes aux lettres

set folder=imap://mail.indie.host:993

Messages non envoyés

set postponed=imap://mail.indie.host:993/Brouillons

Messages envoyés

set record=imap://mail.indie.host:993/Messages Envoyés

Type d’authentification

set imap_authentification=“login”

login et mot de passe

set imap_user=<my mail adress……user@domain>
set imap_pass=

activate TLS if available on the server

set ssl_starttls=yes

always use SSL when connecting to a server

set ssl_force_tls=yes

Could you help me, please ?


#2

There is a good wiki here:
https://wiki.archlinux.org/index.php/Mutt#IMAP

does it help?

Thanks


#3

Bonjour,

j’avais zappé d’aller voir chez Archlinux… la fatigue.

Ça marche.
Merci.


#4

Ça marche pour la réception.
Mais pas pour le SMTP

Cela m’indique que “l’authentification SASL a échoué”

Je reçois mais ne peux envoyer. J’ai essayé la proposition d’Archwiki et d’autres sur d’autres tutos…

set realname = ‘Bxxxx xxxxxt’
set from = bxxxxx@xxxxt.org
set use_from = yes

set smtp_url=“smtp://myname@mydomain.org:587/”
set smtp_pass=“myfu****pw”
set ssl_starttls = yes
set ssl_force_tls = yes
set ssl_verify_host = no
set ssl_verify_dates = no

Quoi qu’y a qui marche pas ???


#5

smtp_url: c’est mail.indie.host le domain.

set ssl_force_tls = no (je pense)

Ou est le smtp user? Dasn notre cas, c’est l’email.


#6

voili voilou…

Je pense que c’est corrigé comme ceci :
set smtp_url=“smtp://{my@user.xxx}@mail.indie.host:587/”

et là, ça marche !


#7

Voici une configuration qui fonctionne.
Après, je crois qu’on peut améliorer le truc…
Si je le fais à l’usage, j’éditerai ce message (ou ajouterai des éléments…)

Merci

#imap
set folder = imaps://mail.indie.host/
set imap_user = user@domain.xxx
set imap_pass = mypassword
set spoolfile = +INBOX
mailboxes = +INBOX

set header_cache = ~/.cache/mutt
set message_cachedir = “~/.cache/mutt”

unset imap_passive
set imap_keepalive = 300
set mail_check = 120

SMTP

set realname = ‘Your real name’
set from = user@domain.xxx
set use_from = yes

set smtp_url=“smtp://user@domain.xxx@mail.indie.host:587/”
set smtp_pass=“mypassword”
set ssl_starttls = yes
set ssl_force_tls = no


#8

Pour ceux qui utilisent le protocole POP…
Ma config Getmail dans le

getmailrc :

[options]
#print out some information
verbose = 1
#just read new mails
read_all = false
#don’t delete the mails on the server
delete = false
message_log = /home/user/.mail/getmail/log

[retriever]
type = SimplePOP3SSLRetriever
server = mail.indie.host
username = user@domain.org
password = yourpassword

[destination]
type = Maildir
path = path/to/maildir/

pour celleux qui utilisent Maildrop pour filtrer leurs mails.

il faut indiquer ceci dans le fichier getmailrc pour [destination] :

[destination]
type = MDA_external
path = /usr/bin/maildrop
arguments = ("-f", “%(sender)”, “path/to/maildroprc”)


#9

Depuis peu, impossible d’envoyer un mail, le message retourné “L’authentification SASL a échoué”

La solution est d’ajouter la ligne suivante dans muttrc :

set smtp_authenticators="plain"

#10

Du coup, le nouveau format pour

SMTP

set smtp_url=“smtp://user@domain.xxx@mail.indie.host:587/”
set smtp_pass=“yourpassword”
set ssl_starttls = yes
set ssl_force_tls = yes
set smtp_authenticators=“plain”