I cannot sync my contacts on my Mac and on my iPhone


#1

I am the proud owner of a Personal Plan at Indie Hosters. I’ve managed to sync everything correctly across my Mac and my iPhone (mails, calendar, files) except for the contacts.

I started by following indications on this post : https://forum.indie.host/t/how-to-configure-your-email-cloud/54 but the mobileconfig file didn’t seem to work. I had an error (for which I can’t post a picture as I’m limited to only one picture for this topic so I save it for later). Basically it says that an error occurred “ProfileDomainPluginController:101” without additional explanations.

Then I tried to manually add the accounts individually. It worked for the Mail account and the CalDav account using the parameters provided. But it didn’t work for the CardDav. Bellow is the error I faced:

I tried various port and server options but nothing worked. Could you help me with a configuration that would work.

Thanks for your help.

Fabien


#2

For the mobileconfig, yes, We have to fix it.

With the manual configuration, I just managed to make it working with this:

https://cloud.indie.host/remote.php/dav/addressbooks/users/username/contacts/

Also I see that:
https://docs.nextcloud.com/server/12/user_manual/pim/sync_osx.html

Does it help?

Thanks for reporting this!


#3

Interesting - I got the problem the other way around.
Using “https://cloud.indie.host/remote.php/carddav/” enabled contacts-sync on my iPhone (don’t have a mac) but I can’t seem to get it to sync my calendar.

EDIT: Great - following Pierre’s second link fixed it now (didn’t work yesterday though)


#4

@Fakrae you confirm that contacts are working?

Now, just the calendar doesn’t work?

Thanks!


#5

Just confirmed: Contacts are working with address:
https://cloud.indie.host/remote.php/carddav/principals/users/USERNAME/
Calendars are working with address:
https://cloud.indie.host/remote.php/dav/principals/users/USERNAME/

Using iPhone8+ with (obviously) iOS 11.
BUT!! contacts do only sync when given my email-address as username for login (username for address has to be account-username) - calendars on the other hand work just fine both with account-username. (They differ due to using a test-account I think)

(on emClient on my windows-machine both work using the same address: https://cloud.indie.host/.well-known/caldav and account-username as credentials)


#6

Thanks for your help. It finally did work on my Mac and my Phone with following config:
Server address: https://cloud.indie.host
Server path: /remote.php/dav/principals/users/USERNAME/
SSL: activated
Port: 443

I don’t understand why everyone has a different working config. The one you shared didn’t work for me.


CalDAV and CardDAV broken on iOS
#7

Just to let other people know what worked in my case (I have an iPhone 4S with iOS 9.3.5): both my Calendar and Contacts settings use the same URL:

Note that is the full firstname.lastname@indie.host
Both use my username and password for authentication, and use SSL + port 443.

Cheers


#8

Thanks to let people know.