Gnome Agenda unable to connect to my indie.host agenda


#1

Hello,

I recently started using gnome agenda. It works fine with one of my other nextcloud agendas (on framadrive) but it does not for my nextcloud agenda on indie.host. Nothing gets displayed and the account is greyed in the agendas list.
The log gives the following error:

gnome-calendar[4711]: source_credentials_required_cb: Failed to authenticate ‘myname’: L’URL indiqué « https://myname%40indie.host@cloud.indie.host/remote.php/caldav/calendars/myname@indie.host/personal/ » ne référence pas un agenda CalDAV

FYI I am using the cloud service of ubuntu to connect to my account. Files are working fine.

Could it be that gnome agenda does not like the @indiehost inside the username? (so twice).

Thanks for your feedback!


#2

Hello,
We had some issues with the synchronisation for calendars and contacts. It should be fixed now. Can you try again.


#3

\o/ yeah it’s working now!
Thank you!


#4

I have this problem again


#5

@EtienneM can you detail from which client do you have issues? and what is the error message?

I just tried and looks fine.

Thanks


#6

The error message in Evolution:

Failed to connect calendar “<username>@cloud.indie.host : <calendar name>”
Given URL “https://<username>@cloud.indie.host/remote.php/caldav/calendars/<username>/<calendar name/” doesn’t reference CalDAV calendar

But it used to work.

Not sure if related, but my phone Nextcloud application to sync files is also showing up an error notification:

Échec de l'envoi
Aucune instance du serveur n'a été trouvée

#7

About the dav, I just tested with davdroid, and if you take the
address from Nextcloud web ui, you get:

<username>/<calendar_name>/

And it worked, can you test with this URL?
(I don’t know what changed, and I’d agree that this is annoying…)
About the phone, I don’t know what it is, but if you can’t fix it,
please open a new thread.
Pierre


#8

Actually on Gnome you don’t chose the URL for the calendar. You just specify your Nextcloud instance address and it automatically syncs calendar, contacts, and files. It worked up to know so I don’t really understand what happened there.

I will open the thread for the phone issue.

Thanks


#9

Bonjour.
Même problème chez moi: impossible de synchroniser agenda et carnet d’adresses sur Gnome Agenda (ubuntu 18.04) alors qu’un autre agenda (zaclys) se synchronise parfaitement.
Pas de message d’erreur; mon compte indie (toit comme mon compte zaclys) est configuré via l’outil compte en ligne d’Ubuntu.
Toute aide sera bienvenue.
Merci par avance.
F. Moureau


#10

pareil ici, j’utilise Ubuntu 18.04 et j’ai configure mon compte Nextcloud dans les “online accounts”, mais rien n’apparait dans le calendrier. Quand j’ouvre “Calendar”, je peux voir les noms de mes calendriers IndieHost dans le menu (deuxieme icone a droite), mais les evenements n’apparaissent pas.


#11

Bonjour,
j’ai le même problème actuellement.

Gnome Agenda ne lit au mieux qu’en “lecture seule”
Evolution donne la même réponse que précédement, pour EtienneM.
edit : voici le message d’Evolution : “L’URL indiqué « https://bertrand%40pinlet.org@cloud.indie.host/remote.php/caldav/calendars/bertrand@pinlet.org/eedfinfo/ » ne référence pas un agenda CalDAV

En outre, mon client Nextcloud prédent qu’il n’y a “Aucune connexion au serveur Nexcloud à l’adresse https://cloud.indie.host. l’opération est annulée.”

J’ai essayé d’installer, réinstaller, etc. Ça ne se connecte pas.

Y’a-t-il un souci, actuellement ?

Mon OS est une Debian testing. Cela vient peut-être de là. Mais je ne saurais dire.

Si vous avez des pistes de correction de problème, c’est bienvenu.

Amicalement,


#12

En plus du problème avec Gnome Calendar, je viens de voir que j’ai exactement le problème décrit plus haut dans Evolution.

Pour info, j’utilise :

  • Gnome Calendar 3.28.2-0ubuntu0.18.04.1
  • Evolution 3.28.1-2
  • Sur Ubuntu Budgie 18.04

Mais si comme moi vous ne pouvez pas utiliser les calendriers Indie Host avec ces deux-là, ça marche quand-même avec Thunderbird et Lightning (j’utilise la version 52.9.1).


#13

Non, moi, même Thunderbird ne fonctionne pas.

Quand après la configuration du calendrier (ics), je dois cocher la case “switch on” pour activer le calendrier, mais il se décoche seul… c’est assez dingue.


#14

Est-ce que tu as essayé avec l’adresse CalDav au lieu de l’option ICS ? C’est ce que j’ai utilisé : le format https://cloud.indie.host/remote.php/dav/calendars/<nomdutilisateur>@indie.host/default/

C’est l’URL fourni par le choix “link” à droite du nom de chaque calendrier quand tu es dans https://cloud.indie.host/apps/calendar.


#15

oui, j’ai essayé cette solution sans succès.

De toutes manières, il est possible de paramétrer un compte nextcloud dans Gnome, mais depuis quelques temps, il indique qu’il est déconnecté. On a beau entrer le mot de passe, il demande de se connecter.

Pourtant l’appli Nextcloud fonctionne.

Le problème est que l’appli ne gère pas les calendriers…