CalDAV and CardDAV broken on iOS


#1

I am having issues adding the cloud.indie.host CalDAV and CardDAV services to my iOS devices running iOS 11.3.

These issues are consistent across two iOS devices. I was able to add them in Linux fine.

First I put in all the details provided by cloud.indie.host:

(remaining screenshots are pending mod approval)


#2

Then it attempts to verify them:

And then says it cannot connect via SSL and I try again without it:

Then that fails too.

I have tried using both my main indie.host password and a custom app password.

The same thing happens when using CardDAV:


#3

If I may just add my voice to this topic… I have the same problem here with iOS7. Tried every solution I could find online, tried every variation to the URL, nothing works.
Any known working solutions?

Update: I also tested with an iPad running iOS 10.11 and there for whatever reason, it worked? What am I not getting?


#4

@sirredbeard Oh, in case you haven’t seen this, you might want to check this topic here:

None of the proposed solutions worked for me, but might work for you.


#5

I have the same problem but on android 8. I simply can’t use my self hosted solution since I got my new P20 lite
I tried all the different ways to add a server in the Davdroid app I can’t have it to run like it used to…


#6

Hello,

I have the exact same problem (just like in the screenshots).
I tried the same method with the CalDAV services from framagenda.org (because they also use NextCloud), and in their case everything works perfectly and gets synchronized.

Thank you by advance!


#7

Really sorry for the long silence :confused:

Have you tried this? There is a mobileconfig that should just work - but as you said you tried everything, then it will not :confused:

We plan to update to the latest version of the server, and it should ease the pain.

Actually, I just changed a parameter, and I think I just corrected it :confused: Happy that I found the way, but really sad it took that much time to fix it…

I plan to write a blog post about that. I think it is worth it, and the problem is that I still don’t fully understand why, but well, it is fixed…


#8

Hi Pierre
Was the mobileconfig file updated with the fix? Or was the fix server-side?